EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Callback filter no longer working

Also by EldoS: CallbackProcess
A component to control process creation and termination in Windows and .NET applications.
#9826
Posted: 04/27/2009 11:14:46
by Dan Cooper (Basic support level)
Joined: 06/27/2007
Posts: 125

I have a strange situation on one of my development machines. I have been working quite happily with callback filter for a while without any issues when today I tried to use it and I do not get any notifications.

The same code works perfectly on a different machine. I have tried uninstalling and re-installing the driver with no effect. I can confirm with driverview.exe that the driver is installed, my calls to AddFilterCallbackRule return true and AttachFilter does not throw an exception but I don't get any callbacks.

I realise this is probably down to something changing on my machine but I cannot figure out what it could be. Do you have any suggestions as to where I should start looking?

Thanks.
#9850
Posted: 04/28/2009 09:06:10
by Vladimir Cherniga (EldoS Corp.)

Make sure that CallbackFilter::GetDriverStatus() returns with status = SERVICE_RUNNING (look at the samples like CBFilter).
When uninstalling driver, make sure that registry entry HKLM\SYSTEM\CurrentControlSet\Services\CBFilterFS is fully deleted. If it isn't, remove it manually or call CallbackFilter::UninstallDriver() untill exception with error status will be thrown. Then install driver again.
If it doesn't help i will put here driver debug version with debugging messages that could be traced with such tools like DbgView and we will try to resolve the problem in this way.

Reply

Statistics

Topic viewed 4448 times

Number of guests: 2, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!