EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Callback File System Questions

Also by EldoS: CallbackProcess
A component to control process creation and termination in Windows and .NET applications.
#11906
Posted: 12/11/2009 01:04:31
by Takhir Bedertdinov (Premium support level)
Joined: 12/11/2009
Posts: 14

We (QStar Technologies) have problem with new drive notification for WinExplorer on few XP Home and Pro computers (but not all). Drive is accessible in CLI, but not in Explorer. Starting process is running as service. Driver version 2.5.54. Situation also reproduces on Win7, but not on server line Windows OSs. Can I do something to clarify this problem for you? Or should I wait for CBFS 3.0 instead (when)?
#11908
Posted: 12/11/2009 01:26:33
by Eugene Mayevski (EldoS Corp.)

I suppose that you install VSMntNtf.dll and that you have checked that this DLL is loaded (present in Explorer's address space at least) at the moment the disk is mounted, haven't you? If you haven't, please do this - it can be that the DLL is not installed or is not loaded.

There will be a new build of 2.5 available tomorrow (most likely), and some improvements in VSMntNtf.dll have been made.


Sincerely yours
Eugene Mayevski
#11909
Posted: 12/11/2009 01:28:47
by Eugene Mayevski (EldoS Corp.)

Also, please assign the license ticket to your user account as described in the registration e-mail. Your company has a company license and the ticket is assignable to any number of accounts. Doing this will let us recognize you as a registered customer and provide Standard technical support.


Sincerely yours
Eugene Mayevski
#11917
Posted: 12/11/2009 11:53:15
by Takhir Bedertdinov (Premium support level)
Joined: 12/11/2009
Posts: 14

Thanks, Eugene!
I re-tested all steps on one of "problem" computers (Toshiba notebook, Windows XP Home Edition 2002 SP2):
Installation (NSIS script) - InstallDriverA, InstallHelperDllA - True returned.
VsMntNtf.dll presents in window\system32 and in the address space of Explorer.exe (Process Viewer). But mounted drive is visible/available in CLI only.

BTW Win7 problem looks following now - drive not appear if mount was done shortly after Remote Desktop login, when network icon on tray bar still has yellow checkmark. Later (normal icon, network fully started) mount is OK.
#11918
Posted: 12/11/2009 12:22:02
by Eugene Mayevski (EldoS Corp.)

Please post a couple of lines of code, where you create a mounting point. This will let us understand, what kind of mounting point we are talking about.

Also, does the problem happen only with RDP or also with local logins?


Sincerely yours
Eugene Mayevski
#11930
Posted: 12/14/2009 03:40:14
by Takhir Bedertdinov (Premium support level)
Joined: 12/11/2009
Posts: 14

I removed functions decoration, and this is sequence of calls in mount procedure:

MultiByteToWideChar(CP_UTF8, 0, mount_point, -1, g_MountingPoint, _MAX_PATH-1);

g_CbFs.SetRegistrationKey(sRegKey);
g_CbFs.SetUseSystemCache(TRUE);
g_CbFs.CreateStorage();

g_CbFs.SetTag(&publish);

g_CbFs.MountMedia(0);

g_CbFs.AddMountingPoint(g_MountingPoint);


Explorer notification issue has place for local (0) desktop, not remote desktop.

Win7 problem reproduces both for remote desktop and local connection.
#11933
Posted: 12/14/2009 04:24:58
by Eugene Mayevski (EldoS Corp.)

The developer is investigating the problem.

BTW new build is available on the site.


Sincerely yours
Eugene Mayevski
#11947
Posted: 12/14/2009 09:43:38
by Eugene Mayevski (EldoS Corp.)

Unfortunately our tester can't reproduce the issue (at least with build 56, which was released yesterday). If you still have a problem with this build, can you please create a small test case which illustrates a problem, and post it's source code here (please put both the source code and project file to ZIP archive).


Sincerely yours
Eugene Mayevski
#11982
Posted: 12/24/2009 02:50:00
by Takhir Bedertdinov (Premium support level)
Joined: 12/11/2009
Posts: 14

Build 56 looks good on XP Home, thanks! Sorry for delay, I still waiting test results for virtul Windows XP Pro on MAC, I'll let you know if problem persists.
But I have another question. For files located on offline media (operator assistance required for import) QStar returns 'offline' error and our CBFS code replaces it with Win API ERROR_MEDIA_OFFLINE. But Windows client program gets 'device not functioning' error instead. I added special debug message to ReadFile function confirming that throw ECBFSError(error); was called with this error code
Code
    if(error == QSE_IN_SET_MEDIUM_OFFLINE)
    {
       error = ERROR_MEDIA_OFFLINE;  // WinError.h  4304L
       q_print_message("_cbfsmount", NULL, "q_ufsi_page_fault ERROR_MEDIA_OFFLINE");
    }
    else q_print_message("_cbfsmount", NULL, "q_ufsi_page_fault error");
    throw ECBFSError(error);

log:
12/23/2009 17:43:36 ERROR MM (sdf_rw, e:\sim\sdf_rw)-0: ..\..\source\mcfs\lib\cfs_archive.c.2143: Error from migrator: PAGE_FAULT \level_01_dir_0000\file_0000_type_offset.dat: Medium in set is offline
12/23/2009 17:43:36 _cbfsmount: q_ufsi_page_fault ERROR_MEDIA_OFFLINE

Offline file copy attempt:
E:\ws_51>copy Y:\level_01_dir_0000\file_0000_type_offset.dat .
A device attached to the system is not functioning.
0 file(s) copied.

I am getting the same error from our C-tool for read/write test. May be I do something wrong?
#11983
Posted: 12/24/2009 03:38:36
by Volodymyr Zinin (EldoS Corp.)

Hello Takhir,

It seems that the problem is because CallbackFS, before returning errors to the kernel, converts them from the win32 error codes into the native ones using the table of errors that doesn't contain all error pairs yet. That's why some errors are converted into the default value STATUS_UNSUCCESSFUL.
ERROR_MEDIA_OFFLINE is also translated to STATUS_UNSUCCESSFUL. Of course we can add a record for this error translation in a future release but now you can try to use the ERROR_FILE_OFFLINE code (it has already been translated into STATUS_FILE_IS_OFFLINE).
Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.

Reply

Statistics

Topic viewed 24374 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!