EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Upgrading to CBFS6 shows contents of virtual disk as files 4Kb in size

Also by EldoS: MsgConnect
Cross-platform protocol-independent communication framework for building peer-to-peer and client-server applications and middleware components.
Posted: 07/15/2016 06:50:57
by Alex Stoev (Standard support level)
Joined: 05/09/2012
Posts: 1


We've recently tried from CBFS5 to CBFS6, but there appears to be a problem after adding mounting points as folders.

This is example of how it worked with CBFS 5.0.143 - after adding mount point and navigating to it in the Windows Explorer, that's how contents looked like:

And this is how it works with CBFS 6.1.180 - same process as above, but all content is displayed as files 4Kb in size:

This is a code in question:



cbfs_.AddMountingPoint((*GetMountPointGenerator()).local_path().c_str(), CBFS_SYMLINK_MOUNT_MANAGER|CBFS_SYMLINK_LOCAL, 0);

ShareResource(); //<- treat as noop in this case

data_cache_ = DataCache::Create(this); //<- treat as noop in this case

Could it be that there were some API changes between these versions which now results in this problem?
Posted: 07/15/2016 07:27:29
by Volodymyr Zinin (EldoS Corp.)

There have not been any changes in that code since then. Could you try to reproduce the problem with the Mapper (or another) sample? And if it is reproducible please create a ticket in HelpDesk.




Topic viewed 416 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!