EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Download to mounted drive with Chrome and IE fails

Posted: 07/15/2016 05:42:16
by vertical gmbh (Standard support level)
Joined: 06/29/2016
Posts: 2


I've got an issue when I want to download a file from a web browser directly to a mounted drive. I'm using CBFS updated to latest version 6.1.181.

I can reproduce the problem with the Mapper example and for now just wondering if there is missing an event by CbFs maybe.

Steps to reproduce:
- Mount a drive with mapper-example
- download a file with Google Chrome or MS IE and choose "Save as"
- Save file to mounted drive
Everything works fine
- now redo the download and this time replace the existing file
Result on my side: Google Chrome downloads the whole temporary file but then hung up (and have to be closed - cancel the download does not solve freezing). In IE I just got response that the download failed.
By the way Firefox works well for this.

I already found out that the problem is the existing file. When the file is not there the browser first create the file to delete it directly afterward. If I block this deletion the download also fails like described.

So the process on downloading (in chrome) for e.g "test.txt" seems to be as followed (if the file not already exists):
- Create test.txt
- delete test.txt
- create test.txt.crdownload
- write downloaded data to test.txt.crdownload
- rename test.txt.crdownload to test.txt
- download finished successful
With a lot of read fileinfo and open/close file events in between.

When the file already exists step 1 and 2 are obviously missing. And after writing "test.txt.crdownload" there starts a loop of open/close the ".crdownload" and the existing "test.txt" file but the renaming-step is never reached.

I tried a lot with telling the system the file actually doesn't exist and few other things but nothing worked.
So I just want to be save that there is no bug in CbFs. Maybe you know about this issue or have a workaround to solve this problem.

Thanks a lot and kind regards

Lutz Moeller
Posted: 07/15/2016 06:16:00
by Volodymyr Zinin (Team)

Hello Lutz,

Thank you for the detailed description of the problem. As I know similar problem has already been fixed in the version 6.1.180. I have tried to reproduce it with the C++ Mapper sample but without success. Could you reinstall the latest cbfs.cab, reboot the machine if required and then try to reproduce the problem?

Posted: 07/15/2016 07:49:43
by vertical gmbh (Standard support level)
Joined: 06/29/2016
Posts: 2

Hallo Volodymyr,

that fixed it! :)
I was still running on 6.1.179. I installed and referenced the v6.1.181 but didn't reinstall the driver on my local machine.

Thanks a lot.
Posted: 07/23/2016 12:52:34
by Eugene Mayevski (Team)

Thank you very much for reporting the outcome to us -- this will let other users in similar situations know what to do.

Sincerely yours
Eugene Mayevski



Topic viewed 3877 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!