EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Issue on opening PDF with Adobe Reader

Also by EldoS: Rethync
The cross-platform framework that simplifies synchronizing data between mobile and desktop applications and servers and cloud storages
#36934
Posted: 06/08/2016 10:44:55
by Lutz Moeller (Basic support level)
Joined: 05/27/2016
Posts: 8

Hallo,

I've got a problem when I open a PDF with Adobe Reader. (For local stored files as well as for remote stored)
Main problem is: the OnReadFile event is never called. "OnFileOpen" and "OnFileClosed" is called multiple times but nothing else.

Other files work well and even if I open the pdf with another program (like Firefox) everything works fine. At least when I open the PDF in Adobe Reader via the "Open"-Dialog in the program it works. Only the double click in the explorer not.

Does anyone else have this problem before?
I checked other filetypes and programs and don't have this anywhere else.

Thank you a lot
#36938
Posted: 06/08/2016 12:00:15
by Eugene Mayevski (EldoS Corp.)

First, could you please tell us the version of Windows, that you are using?

Next, did you check some of our samples or only your code?


Sincerely yours
Eugene Mayevski
#36954
Posted: 06/09/2016 15:38:49
by Lutz Moeller (Basic support level)
Joined: 05/27/2016
Posts: 8

I'm really sorry about my less detailled post.

I'm testing on a Windows 8.1 x64 OS, but also got this problem with a Windows Server 2012 for example.
I think there is something wrong in my implementation. Your samples work fine, but I can't really figure it out.
The main problem seems to be, that the file system tries to open another file while reading the main one.
I noticed that if I open a txt file with notepad the title of the window got the name of an other file in my folder. But the shown content is from the original one.
So most programs seem to have no troubles about this wrong handling, but maybe the Adobe Reader does. Until now that's my only track.

Do you hear about that any time before?
#36963
Posted: 06/10/2016 04:07:47
by Volodymyr Zinin (EldoS Corp.)

We have not heard about that before.
Perhaps Process Monitor from Microsoft can help. It's an utility which shows what operations occur on the file system level. Execute it and reproduce the problem. Better if you reproduce it in a maximally simple manner. For example run cmd.exe and open the file from there (because use of Explorer causes too many additional operations to occur). Then look the logs and correlate them with your CBFS callbacks. In order to minimize number of logs use the filter rules in Process Monitor. For example to show operations only for your CBFS virtual disk add the rule "Path"->"begins with"->"X:", where "X:" is drive letter to the disk.

Thanks.
#36965
Posted: 06/10/2016 08:19:24
by Lutz Moeller (Basic support level)
Joined: 05/27/2016
Posts: 8

I analyzed the problem with the process monitor and I'm really confused.

In the attachments there is a screenshot of a part of the process when I open a PDF (in this case "SomePdf.pdf") from Windows Explorer.
I figure out that the process always use one file (in folder) as "Path" (in this case: "default_image_name.jpg") but opens the right content (AllocationSize is correct, Content is correct). If I delete "default_image_name.jpg" and open "SomePdf.pdf" again the process take even another file from the folder as path (for example "SomeText.txt"). Seems to be very random which one, but I might be wrong.

I know this may be no issue of CBFS but maybe you know how to fix it?
I'm also going to search for the reason.

Thanks a lot

Update: I mount the virtual drive as a network drive - maybe thats good to know

Update 2: I maybe found the solution. I handled the mask parameter wrong in EnumerateDirectory. I check if this is the problem and let you know...


#36969
Posted: 06/10/2016 10:05:41
by Lutz Moeller (Basic support level)
Joined: 05/27/2016
Posts: 8

Blame on me..

I missunderstood the meaning of the "Mask" parameter in "OnEnumerateDirectory"

Thought it would be for explorer integrated search and decided to implement that later.
Now I handle it right and everything works fine.

Thanks for your patience and support!
Also by EldoS: BizCrypto
Components for BizTalk® and SQL Server® Integration Services that let you securely store and transfer information in your business automation solutions.

Reply

Statistics

Topic viewed 1600 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!