EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Problem witing large files

Also by EldoS: CallbackRegistry
A component to monitor and control Windows registry access and create virtual registry keys.
#3418
Posted: 07/19/2007 18:47:45
by Stefan Stefan (Basic support level)
Joined: 07/18/2007
Posts: 15

Hello :D
Sorry to bother again but I do have another problem. I am sure it's my fault but although I have spend some hours(!) to figure out what's going on I have absolutely no idea :cry:
Ok. Here it is:
I am transferring a larger file (>50 MB) to a mounted volume. Almost immediately there's a yellow triangle and a balloon hint in my traybar which notifies me that not all data could be written to "\Device\CbFsStorages\CbFs0\filename.txt". Cbfs keeps on working and my log shows, that there are subsequent write operations happening but everyhing is slowing down consideribly. The really strange thing is: there is no exception. Nothing at all.
I would like to add that everything is working pretty well when transferring even dozends of files at once. But as soon as one is larger than appr. 50 MByte the problem arises.
Has anyone an idea what could cause this behaviour?
Regards
Stefan
PS: There has been one exception afterwards when reading FCbfs.Active: a semaphore timeout, errorcode 121.
#3419
Posted: 07/20/2007 01:10:38
by Eugene Mayevski (EldoS Corp.)

Some problems with large files were reported in build 1.0.7 due to incorrect approach to setting file sizes. In version 1.0.8 we fixed this and the problems has gone away. If you use 1.0.8 or 1.0.9 and still have a problem, please create a test case cause we were not able to reproduce the issue in 1.0.7 (the fix was made blindly).


Sincerely yours
Eugene Mayevski
#3421
Posted: 07/20/2007 01:28:49
by Stefan Stefan (Basic support level)
Joined: 07/18/2007
Posts: 15

Hello!
There have been two problems. One was that I did Mount the volume with a timeout which was probably too low (1000). The other one was a bit more hard to find. During writing the buffers to disk there was sometimes a rather long delay. I have added FILE_FLAG_WRITE_THROUGH to CreateFile and this solved the problem.
Regards
Stefan
#3422
Posted: 07/20/2007 02:04:32
by Eugene Mayevski (EldoS Corp.)

Can you please tell us in more details about the long delay? What file did you set FILE_FLAG_WRITE_THROUGH for, i.e. was it the file on the virtual storage or the file which is a container for your data?



Sincerely yours
Eugene Mayevski
#3792
Posted: 09/18/2007 04:54:22
by Dan Cooper (Basic support level)
Joined: 06/27/2007
Posts: 125

This appears to be the issue I am having also on version 1.0.11, I have started a new thread about it and I am trying to put together a test case now.
Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.

Reply

Statistics

Topic viewed 4399 times

Number of guests: 2, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!