EldoS | Feel safer!

Software components for data protection, secure storage and transfer

win8.1 network drive not visible in explorer

Also by EldoS: CallbackFilter
A component to monitor and control disk activity, track file and directory operations (create, read, write, rename etc.), alter file data, encrypt files, create virtual files.
Posted: 04/15/2014 07:44:11
by Andrew Solonovich (Standard support level)
Joined: 04/05/2013
Posts: 12


After moving to cbfs5 and win8.1 I've seen that cbfs drive is not visible in explorer.
But in total commander it is visible and works good. I tried to copy path from TC to explorer - it fails. In open-save file dialog drive is visible.

I tried to pass same parameters in AddMountingPoint() procedure in Mapper example as we use in our app and get same results - in explorer drive is not visible.
Here parameters I used:
mCbFs.AddMountingPoint(edtMountinPoint.Text, CallbackFileSystem.CBFS_SYMLINK_NETWORK | CallbackFileSystem.CBFS_SYMLINK_LOCAL, null);//CallbackFileSystem.CBFS_SYMLINK_MOUNT_MANAGER, null);

So question is - where I'm wrong?
I want to have non shared network drive and in cbfs4 it works ok with this parameters.

Thanks in advance.
Posted: 04/15/2014 08:52:23
by Volodymyr Zinin (EldoS Corp.)

Hello Andrew,

Perhaps you run the application which creates the mount point with elevated rights (i.e. "run as administrator"). In this case the local mount point is created in a separate special session that is different from the current logon session.
Please check it first.
Posted: 04/15/2014 09:15:25
by Andrew Solonovich (Standard support level)
Joined: 04/05/2013
Posts: 12

Vladimir, thank you for the quick answer!

You are right - I run program from Visual Studio which was run from Total Commander which was run with elevated rights.
If I run my program from Explorer - drive is visible.

But why it is still visible when I run Mapper from Visual Studio with only one flag CallbackFileSystem.CBFS_SYMLINK_MOUNT_MANAGER ?
Posted: 04/15/2014 09:31:47
by Volodymyr Zinin (EldoS Corp.)

In the case of CBFS_SYMLINK_MOUNT_MANAGER a globally visible mount point is created. I.e. it is visible for all sessions. Actually it's preferable to use either CBFS_SYMLINK_MOUNT_MANAGER or CBFS_SYMLINK_NETWORK because they are native for Windows.
In the case of CBFS_SYMLINK_SIMPLE there can be problems with some applications. For example the default image viewer on Windows 8 (which is metro-application) doesn't show images via such mount point.



Topic viewed 1519 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!