EldoS | Feel safer!

Software components for data protection, secure storage and transfer

CreateStorage throws exception "Incorrect Function"

Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.
#23226
Posted: 01/16/2013 19:17:40
by Zohrab Broyan (Basic support level)
Joined: 01/16/2013
Posts: 2

I'm trying to run the sample Mounter and VDisk project. The driver is installed properly (I do see cbfs4.sys file under Windows/System32/Drivers folder). When I click on "Create Storage", a popup window comes up and asks for the license key. I have the evaluation license key, which I enter. After I click OK, I get the "Incorrect Function" message.

I'm running on Windows 7 Professional 64 bit machine. Using VS 2010.

I did debug the code, and it fails when it calls CreateStorage() method. Error Code is 1. I also checked Event Viewer, and here's what I see in there:
Code
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="cbfs4" />
  <EventID Qualifiers="0">1</EventID>
  <Level>2</Level>
  <Task>0</Task>
  <Keywords>0x80000000000000</Keywords>
  <TimeCreated SystemTime="2013-01-17T00:50:09.000000000Z" />
  <EventRecordID>72716</EventRecordID>
  <Channel>Application</Channel>
  <Computer>BLAHBLAHBLAH</Computer>
  <Security />
  </System>
- <EventData>
  <Data>1</Data>
  <Binary>1101...6300</Binary>
  </EventData>
  </Event>


Your help is greatly appreciated.

Thanks,
Zohrab
#23227
Posted: 01/17/2013 00:14:49
by Eugene Mayevski (EldoS Corp.)

Please run Mapper sample and see whether it shows version number - this indicates that the driver was installed to the OS properly.


Sincerely yours
Eugene Mayevski
#23244
Posted: 01/17/2013 10:26:24
by Zohrab Broyan (Basic support level)
Joined: 01/16/2013
Posts: 2

Yes, it shows "Driver (ver 4.0.128.312) installed, service is running".

Thanks,
Zohrab
#25524
Posted: 07/03/2013 09:20:07
by Adin Schmahmann (Basic support level)
Joined: 07/03/2013
Posts: 1

I've run into the same issue with the Mapper and the other demos as well. What was the resolution to this issue? Actually, I found that the error happens when I try to MountMedia after having called CreateStorage. The driver version is 4.0.135.22.

Thanks,
Adin
#25529
Posted: 07/03/2013 14:57:32
by Volodymyr Zinin (EldoS Corp.)

Moved to HelpDesk.
Also by EldoS: BizCrypto
Components for BizTalk® and SQL Server® Integration Services that let you securely store and transfer information in your business automation solutions.

Reply

Statistics

Topic viewed 1648 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!