EldoS | Feel safer!

Software components for data protection, secure storage and transfer

XCOPY command failed in Mapper sample

Posted: 05/08/2015 02:46:59
by Volodymyr Zinin (Team)

William Levra-Juillet wrote:
Right, I've tried to use StorageType to stDiskPnP and StorageCHaracteristics to 0 (non removable). I confirm that xcopy seems to work when avail space > 1TB.

There are no differences in CBFS processing of "fixed" and "removable" disks. So it seems XCOPY doesn't expect that there can be removable disks with such big capacity.

William Levra-Juillet wrote:
But I faced another problem with pnpDisk...

I will check it and write the result here.
Posted: 05/08/2015 10:04:27
by Volodymyr Zinin (Team)

I have tried to reproduce the crash with the C++ Mapper sample but without success. The sample didn't crash. Although when I clicked on the "Populate" button that dialog closed.
Can you reproduce it with the Mapper sample?
Posted: 05/08/2015 10:34:34
by William Levra-Juillet (Priority Standard support level)
Joined: 09/05/2013
Posts: 49

It doesn't crash. The "Unmount" callback is called and the drive disappear :(
I'll see if I can repro with mapper sample.
Posted: 05/08/2015 10:55:28
by Volodymyr Zinin (Team)

Moved to HelpDesk for further investigation.



Topic viewed 9384 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!