EldoS | Feel safer!

Software components for data protection, secure storage and transfer

CbGsNetRdr3.dll is either not designed to run on Windows or...

Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.
#15277
Posted: 12/12/2010 09:09:52
by John Smith (Basic support level)
Joined: 12/12/2010
Posts: 3

Not sure if this is the appropriate place to post this but I'm looking for some trouble shooting help. Lately when opening different applications (Notepad, NNTP client, etc.) I get an error message window that pops up with the following information:

notepad.exe - Bad Image
C:\Windows\system32\CbFsNetRdr3.dll is either not designed to run on Windows or it contains and error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support.

I'm running Windows 7 Enterprise (64-bit), latest updates installed. I have also swept the OS for malware with zero results. What has me stumped is that I have no idea what program is using CbFsNetRdr3.dll. I have tried removing some applications and it hasn't helped.

I also am curious, does Dropbox using this library? If so that *might* be my problem.

Anyway hope someone can help. I'm not a programmer, just came across this place on a Google search for a solution.
#15278
Posted: 12/12/2010 09:29:08
by Eugene Mayevski (EldoS Corp.)

DropBox evaluated Callback File System, but they didn't purchase a license. If you know how to use RegEdit tool, we will give you instructions regarding how to remove CbFsNetRdr3.dll from registry.


Sincerely yours
Eugene Mayevski
#15279
Posted: 12/12/2010 09:30:32
by John Smith (Basic support level)
Joined: 12/12/2010
Posts: 3

Hi Eugene, instructions on how to remove it from the registry would be great, thanks!
#15281
Posted: 12/12/2010 22:47:51
by Vladimir Cherniga (EldoS Corp.)

You should unregister both 32 and 64-bit version dll. In order to do this run the next two commands from command line:

c:\windows\System32\regsvr32.exe /n /u /i:"PRODUCT_GUID" "c:\windows\System32\CbFsNetRdr3.dll"
c:\windows\SysWOW64\regsvr32.exe /n /u /i:"PRODUCT_GUID" "c:\windows\SysWOW64\CbFsNetRdr3dll"

where PRODUCT_GUID is a value used during installing Callback FileSystem driver package. If you don't know this value, open HKEY_LOCAL_MACHINE\SOFTWARE\CallbackFS registry path and read the name of subkey - this is your target PRODUCT_GUID value.

You should also remove "cbfs3" name from the value of the next registry parameter
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order
Reboot the machine when this steps done.
#15433
Posted: 01/08/2011 11:19:02
by John Smith (Basic support level)
Joined: 12/12/2010
Posts: 3

Hi Vladimir, sorry for the late reply. I think the issue is fixed, but I'm posting this in case someone has a similar issue and is looking for a solution via Google or the like. I tried using your instructions but interestingly I don't have an entry in my registry for "HKEY_LOCAL_MACHINE\SOFTWARE\CallbackFS". HOWEVER, I did have "cbfs3" listed under "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order". Removing that appears to have fixed the problem.
Also by EldoS: SecureBlackbox
200+ components and classes for digital security, signing, encryption and secure networking.

Reply

Statistics

Topic viewed 3520 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!