EldoS | Feel safer!

Software components for data protection, secure storage and transfer

VMounter app v3.1.83 runtime error

Also by EldoS: SecureBlackbox
200+ components and classes for digital security, signing, encryption and secure networking.
Posted: 11/29/2010 18:33:22
by Jim Freeman (Standard support level)
Joined: 11/29/2010
Posts: 8

I'm getting a popup from Mounter_VS2008 "The system cannot find the file specifed" on Create Storage after updating from 3.0.78 to 3.1.83. I'm running Win2008R2x64. Here is the sequence that got me to this point:

- 3.0.78 .Net C# Mounter was working fine.
- Ran Mounter and tried Uninstall Driver. Ran into some errors I didn't write down unfortunately. I rebooted and tried this several times. Finally I manually deleted
and rebooted.
- Installed 3.1.83. (forgot to do next step first)
- Ran Windows uninstaller for CBFS.

- Installed 3.1.83.
- Ran 3.1.83 .Net C# Mounter. At the end of Install Drivers a popup says "the specified module could not be found".
- Exited Mounter
- I checked file versions:
- Restarted Mounter.exe, at bottom it says "driver (ver installed, service is running".
- Click Create Storage, get a popup "The system cannot find the file specified". No info about what the filename is.

I can't get past this last error. Not sure if I have created a bad install, or if there is a bug in the new CBFS or Mounter. Any idea how to resolve this?


UPDATE: I just now uninstalled and went back to 3.0.78, now mounter works fine. I still want to make 3.1.83 work though.
Posted: 11/30/2010 03:05:23
by Eugene Mayevski (EldoS Corp.)

The developers have fixed the code (it was a typo that made the file install to c:\windows instead of c:\windows\system32) and I've re-uploaded the files. Please just download it from the site.

Sincerely yours
Eugene Mayevski
Posted: 11/30/2010 13:18:37
by Jim Freeman (Standard support level)
Joined: 11/29/2010
Posts: 8

I just now downloaded the 2nd verion of 3.1.83, but ran into some install issues.

First I uninstalled the previous version 3.0.78, but noticed it didn't remove any CBFS* files from the \windows tree, so I deleted them manually, but I was unable to delete \windows\system32\CbFsMntNtf3.dll from because "file is in use". Sysinternal's procexp.exe shows Explorer.exe is holding the file open; I tried rebooting, but explorer.exe still has it open.

Next I tried installing the 2nd version of 3.1.83. I noticed the installer left the old 3.0.78 version of \windows\system32\CbFsMntNtf3.dll. I didn't see any messages from the installer app about not being able to update that file.

I've attached the install log for 3.1.83 2nd version; I don't see any mention of the \system32 CBFS DLLs, or any mention of install errors.


[ Download ]
Posted: 12/01/2010 04:14:26
by Vladimir Cherniga (EldoS Corp.)

Please check the values under your HKEY_LOCAL_MACHINE\SOFTWARE\EldoS\HelperDlls\2 registry path.
Posted: 12/01/2010 11:32:24
by Jim Freeman (Standard support level)
Joined: 11/29/2010
Posts: 8

The only item in that registry key is Guid713CC6CE-B3E2-4fd9-838D-E28F558F6866 with a value of of 1.
Posted: 12/01/2010 13:02:59
by Vladimir Cherniga (EldoS Corp.)

You posted a log of cbfs install package, it doesn't make any actions specific to dlls or driver installation. Try to uninstall helper dlls with a driver using Uninstall() cbfs api with a cbfs.cab file from the 3.1.83. CbFsMntNtf3.dll will be deleted or if it can't - renamed to CbFsMntNtf3.dll_ and delayed remove will be performed after system reboot. Then you may install all modules and driver with Mapper sample. Just specify the modules to install in Install() method.
Posted: 12/01/2010 20:50:50
by Jim Freeman (Standard support level)
Joined: 11/29/2010
Posts: 8

It looks likethe VMounter source code does "Uninstall() cbfs api with a cbfs.cab file from the 3.1.83" when you click "uninstall drivers". But as mentioned above it doesn't work for me. Does the Mapper sample have different logic for install/uninstall?
Posted: 12/02/2010 02:32:30
by Vladimir Cherniga (EldoS Corp.)

There is no difference which sample to use. Please specify the setting under HKEY_LOCAL_MACHINE\SOFTWARE\CallbackFS registry path.
Posted: 12/02/2010 17:29:46
by Jim Freeman (Standard support level)
Joined: 11/29/2010
Posts: 8

I was able to complete the uninstall of \windows\system32\CbFsMntNtf3.dll which explorer.exe held open by just killing explorer.exe and then deleting the DLL.

So I am now in state where it appears 3.1.83 is installed correctly.
Posted: 12/03/2010 03:37:23
by Eugene Mayevski (EldoS Corp.)

Does this mean that we can treat the issue as resolved (at least for now)?

Sincerely yours
Eugene Mayevski
Also by EldoS: CallbackDisk
Create virtual disks backed by memory or custom location, expose disk images as disks and more.



Topic viewed 4479 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!