EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Possible driver clash with Win7 Activation?

Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.
#13180
Posted: 05/04/2010 12:18:37
by Eric Dahlvang (Standard support level)
Joined: 09/11/2009
Posts: 29

Note: I am NOT using Kaspersky Anti Virus, so it isn't part of the issue. I use Microsoft Security Essentials, and installing the CBFS PnP device did not cause Security Essentials to respond in any way.
#13194
Posted: 05/04/2010 17:36:13
by Chris Schirlinger (Standard support level)
Joined: 02/18/2010
Posts: 38

Ahh for extra information which I realized I had not mentioned, I am building the dotNet C# version of the sample app (and that was what our original program was written in)
Quote
Eric Dahlvang wrote:
...installing the CBFS PnP device did not cause Security Essentials to respond in any way.

Just to clear this up a little, Kaspersky AV only responds when the drive is physically mounted by (our) application (or VMounter sample app). Installation of drivers themselves don't cause a response.

KAV seems to see the drive as it is mounted and respond to it the same way as it would respond to a USB key being inserted or a USB drive being plugged in and offers to scan the new device.
I always clicked "Skip" and never allowed it to scan
#13195
Posted: 05/04/2010 21:07:17
by Chris Schirlinger (Standard support level)
Joined: 02/18/2010
Posts: 38

Tested again (same sample change) with latest version from the server v.3.0.76 Maintenance update

The issue still occurs
#13229
Posted: 05/06/2010 12:36:07
by Eric Dahlvang (Standard support level)
Joined: 09/11/2009
Posts: 29

I know it's only been a couple days, but has there been any progress with this? I'm going to have to reinstall everything on my development machine tomorrow if I can't get this resolved.
#13231
Posted: 05/06/2010 14:06:34
by Volodymyr Zinin (EldoS Corp.)

We have reproduced the problem and are examining it.
#13281
Posted: 05/11/2010 14:01:51
by Volodymyr Zinin (EldoS Corp.)

The problem has been resolved. It seems that one of the system API has a bug (or it's such a feature).
The bug is connected with the PnP virtual storages creation and the bugfix will be available in the next build (it's expected in a few days). In the attachment there is a patch that fixes Windows activation. Execute it on the "deactivated" OSes and follow the instructions.
Sorry for the inconveniences.

In the attachment is a zip-file. Strange but this forum spoils the attached file names.


[ Download ]
#13286
Posted: 05/11/2010 17:55:07
by Eric Dahlvang (Standard support level)
Joined: 09/11/2009
Posts: 29

Thank you for fixing this.
#13330
Posted: 05/15/2010 12:12:44
by Eugene Mayevski (EldoS Corp.)

FYI: New build with a fix is available for download.


Sincerely yours
Eugene Mayevski
#33189
Posted: 05/01/2015 02:26:43
by Wouter Reubzaet (Basic support level)
Joined: 05/01/2015
Posts: 1

Hallo,

I am suffering from a very similar issue, where both Windows 7 and Office 2010 license cannot be validated anymore. I tried every solution on the internet I could find, from GPO setting, registry settings, resetting the license with slmgr.vbs and many more. Even when I restored an older Windows 7 image from long before I got the problem, the problem swiftly returned, after only windows updates and Comodo firewall updates had run. It took me well over 20 hours of frustration. Then I uninstalled the Comodo firewall but the problem persisted. The only think that seemed to work was running the fix you provided above. Now comes the strange part: After applying the fix and rebooting, All licenses work fine, but after some time (hours?) or one or more reboots the problem pops up again. When I apply he fix and reboot again, everything works again. So I have to repeat this process very often. Somehow something is still broken in the Windows license system. I would really like to know what exactly the fix does, so I might be able to pinpoint the cause of this returning error. Can you tell me what exactly the fix does, which files or settings are repaired?
Thank you in advance for any help you can provide.
#33192
Posted: 05/01/2015 11:03:18
by Eugene Mayevski (EldoS Corp.)

Dear Mr.Reubzaet, is your question related to our product (Callback File System) in any way? If no then we can't help you unfortunately.


Sincerely yours
Eugene Mayevski
Also by EldoS: Rethync
The cross-platform framework that simplifies synchronizing data between mobile and desktop applications and servers and cloud storages

Reply

Statistics

Topic viewed 24428 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!