EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Disconnected Network drive in explorer

Also by EldoS: SecureBlackbox
200+ components and classes for digital security, signing, encryption and secure networking.
Posted: 02/02/2010 05:42:45
by Mezeo Support (Basic support level)
Joined: 12/29/2009
Posts: 40

When I mount a callback file system, the drive is reported as disconnected in explorer. I am using cbfs driver with file version as I am not retuning any relevant error code (ERROR_REMOTE_STORAGE_NOT_ACTIVE,
ERROR_CONNECTION_UNAVAIL) resulting into same. I tried this on windows vista. It seems there is no callback to modify the status.
Posted: 02/02/2010 05:55:37
by Volodymyr Zinin (EldoS Corp.)

Have you installed the VSNetRdr helper dll?
Posted: 02/02/2010 06:59:28
by Mezeo Support (Basic support level)
Joined: 12/29/2009
Posts: 40

Are you talking about the network provider DLL ? I see entry in the services key for HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CbFs\NetworkProvider.
Posted: 02/02/2010 07:40:13
by Volodymyr Zinin (EldoS Corp.)

Please specify the following:
- the parameters of the AddNetworkMountingPoint function
- the OS version
- whether the the program runs as elevated (i.e. "run as admin")
- whether the program runs in the same logon session where the mount point is created


P.S. It would be better if you created a ticket in the helpdesk for this problem.



Topic viewed 1320 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!