EldoS | Feel safer!

Software components for data protection, secure storage and transfer

CreateStorage error 0x8007007A

Also by EldoS: RawDisk
Access locked and protected files in Windows, read and write disks and partitions and more.
Posted: 06/24/2009 11:46:58
by Mike Gile (Basic support level)
Joined: 06/02/2008
Posts: 4

Recently I have been testing a CallbackFS-based application in a Virtuozzo container. It seems that the driver is found okay, but when attempting to mount the drive I am encountering the following error reported from CreateStorage():

8007007A The data area passed to a system call is too small.

A few google searches don't shed any light on the situation with regard to CallbackFS. Does anyone know what could cause this error?
Posted: 06/24/2009 12:23:46
by Eugene Mayevski (EldoS Corp.)

I am sorry but we don't support Virtuozzo. Incompatibility of their software with "real" systems is their problem, not ours. While we are obliged to provide compatibility with standard software, custom emulation environments of different level of quality are not always possible to target.

If you are interested in getting support for Virtuozzo, we can work on this problem as a custom service for you.

Sincerely yours
Eugene Mayevski
Posted: 06/24/2009 14:19:27
by Mike Gile (Basic support level)
Joined: 06/02/2008
Posts: 4

Hello Eugene,

I understand that you do not support this out of the box. I am trying to see if I can get it to work myself, which I am partly able to do by forcing driver installation into the container. I am simply asking if you could tell me why that error could be returned from CreateStorage, and I will continue to debug the problem myself.

Posted: 06/24/2009 14:26:19
by Eugene Mayevski (EldoS Corp.)

This is not CBFS error, so we have no knowledge of it. I think that this is what constitutes the problem: if we knew what that error meant, we would know how to work around it.

Sincerely yours
Eugene Mayevski
Posted: 06/26/2009 09:24:41
by Volodymyr Zinin (EldoS Corp.)

Hi Mike,

CallbackFS doesn't return such error itself. Perhaps some system call inside the CreateStorage method is intercepted by Virtuozzo and that causes the error.
I've tried to install Virtuozzo Container 4.0 on Win2003 Enterprise Edition SP2 but without success. During the installation an error occurred "The Virtuozzo KSAL service does not start". Based on the article http://kb.parallels.com/en/1426 it's because of incorrect system configuration. I'll try to reinstall it.
BTW there is Virtuozzo version 4.5RC. Have you tried the problem on it?
Also please specify what it's necessary to do in order to reproduce the problem. Is it possible to do using one of the CallbackFS samples?
Also by EldoS: Solid File System
A virtual file system that offers a feature-rich storage for application documents and data with built-in compression and encryption.



Topic viewed 2289 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!