EldoS | Feel safer!

Software components for data protection, secure storage and transfer

DeleteMountingPoint after AddNetwork Monting Point

Posted: 05/30/2009 12:03:06
by Tim Hayes (Standard support level)
Joined: 06/06/2007
Posts: 36


I am working with Delphi and CBFS v2.51

I have started to use AddNetworkMountingPoint as follows:


FCbFs.AddNetworkMountingPoint(fMountingPoint + ';' + fVolumeLabel + ';' + 'ShareToo',false,nil,[]);

This shows nicely in MyComputer as "ShareToo(\\Server Two)(F:)" and the shell window opens and works OK.

On UNMOUNT I have tried each the following:

// FCbFs.DeleteMountingPoint(0);
// FCbFs.DeleteMountingPoint(fMountingPoint);
// FCbFs.DeleteMountingPoint(fMountingPoint + ';' + fVolumeLabel + ';' + 'ShareToo');

On each variation I get the same error:

"System Error Code 2 : cannot find the file specified"

Where am I going wrong?

Tim Hayes
Posted: 05/31/2009 07:47:32
by Tim Hayes (Standard support level)
Joined: 06/06/2007
Posts: 36

OK now fixed.

I was calling : FCbFs.DeleteMountingPoint(0); from elswhere in the program.

When I replaced this with : FCbFs.DeleteMountingPoint(fMountingPoint); the message went away.

A small note in the documentation as to the correct way to unmount a network mounting pooint would be helpful.

Tim Hayes
Posted: 05/31/2009 08:42:37
by Eugene Mayevski (Team)

Hmm. First of all, FCbFs.DeleteMountingPoint(0); should work too, and, next, you mentioned above that FCbFs.DeleteMountingPoint(fMountingPoint); didn't work for you before (and now it works). I guess there's some problem here that needs to be investigated.

Sincerely yours
Eugene Mayevski
Posted: 05/31/2009 08:53:27
by Tim Hayes (Standard support level)
Joined: 06/06/2007
Posts: 36


I only had one mounting point, so FCbFs.DeleteMountingPoint(0) ought to have been working.

At the time of my original post, I had not noticed that the program was always calling FCbFs.DeleteMountingPoint(0) from another clean-up point in the program, so it was never dropping thru the FCbFs.DeleteMountingPoint(fMountingPoint) code. No need for you to investigate that one but FCbFs.DeleteMountingPoint(index) remains an issue if you expect it to work for network mounting points.

BTW, Network Mounting is really COOL.

Posted: 06/01/2009 07:39:07
by Volodymyr Zinin (Team)


There is a bug in CallbackFS that doesn't allow to delete network mounting points by means of DeleteMountingPoint(index). The fix will be available in the nearest build.



Topic viewed 2442 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!