EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Files are missing

Also by EldoS: CallbackFilter
A component to monitor and control disk activity, track file and directory operations (create, read, write, rename etc.), alter file data, encrypt files, create virtual files.
#6893
Posted: 07/11/2008 02:00:24
by Søren Kristensen (Basic support level)
Joined: 03/04/2008
Posts: 62

When the mapper sample is running I have two "drives/directories" - the virtual drive, let us called it I: and the physical directory say c:\eldostest.

I have done the following:

I create a windows share "Data" for the virtual drive I: and a windows share "Eldostest" for the physical directory.

I connect to both "Data" and "Eldostest" from a client machine.

I then copy many (1500) small files on to the Data share.

In this situation I have seen the following situation. If I use explorer on the "Eldostest" share i see the correct number of files. If I use explorer on the "Data" share i only see about 950 files. Some files are missing when I access the virtual Eldos drive!.

I have seen this problem with the 2.0.34 driver and the test driver 0.0.0.1.

I have also seen this situation in our solution - but with a smaller number of files. The timeout value is set to 0 with the call g_CbFs.MountMedia(0)

What am I missing ?????

Any kind of help will be appreciate.
#6904
Posted: 07/11/2008 14:00:00
by Volodymyr Zinin (EldoS Corp.)

I've reproduced the problem. We'll fix it in a short time.
#6916
Posted: 07/14/2008 06:10:08
by Volodymyr Zinin (EldoS Corp.)

The bug has been fixed. We'll release the new build today or tomorrow.
#6951
Posted: 07/16/2008 11:40:11
by Volodymyr Zinin (EldoS Corp.)

The new build is available.
#7027
Posted: 07/23/2008 03:40:22
by Søren Kristensen (Basic support level)
Joined: 03/04/2008
Posts: 62

Hi

I have downloaded the latest build (2.0.35) and the problem is not seen anymore

#7028
Posted: 07/23/2008 11:25:06
by Dan Cooper (Basic support level)
Joined: 06/27/2007
Posts: 125

I am seeing the same problem, yet I have downloaded the latest from the downloads page which says 2.0.35 but after installing I have version 2.0.34.32364. Is the download link incorrect?
#7029
Posted: 07/23/2008 12:19:12
by Eugene Mayevski (EldoS Corp.)

It often happens that when you download the same URL, some cache returns the old version. To avoid this, modify the URL:

http://www.eldos.com/files/cbfs/cbfs.zip?ver=2035

The part after the question mark will be ignored by our server and the cache manager will download new version.


Sincerely yours
Eugene Mayevski
#7030
Posted: 07/23/2008 13:07:18
by Dan Cooper (Basic support level)
Joined: 06/27/2007
Posts: 125

I tried the link and the file is the same as what I have. My release notes do say 2.0.35 but the .NET 1.1 DLL is version 2.0.34.32364
#7031
Posted: 07/23/2008 13:42:42
by Eugene Mayevski (EldoS Corp.)

Well, for .NET 1.1 assembly the version number has not been updated to 2.0.35. Maybe that's the reason why your DLL is not updated? Or it is updated but the version number is confusing.


Sincerely yours
Eugene Mayevski
#7032
Posted: 07/23/2008 13:44:38
by Dan Cooper (Basic support level)
Joined: 06/27/2007
Posts: 125

Could you confirm whether the .NET 1.1 is the latest build?
Also by EldoS: SecureBlackbox
200+ components and classes for digital security, signing, encryption and secure networking.

Reply

Statistics

Topic viewed 6800 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!