EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Network drive explorer name

Posted: 07/04/2008 05:21:05
by Franck Bonin (Standard support level)
Joined: 09/21/2007
Posts: 27


We faced many problems to replace cbfs network drive defaut name assigned by Explorer.

We finaly succesfully changed it according to our needs using second parameter string of AddNetworkDrive() method and modifiying associated content of registry key located under
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2 (for windows XP and more)

This work well only for explorer windows but not with standard 'open file' dialog windows.

In sush dialog windows, our cbfs network drive name is assigned to system defaut name for network drives.

If we attempt to change it by hand inside this windows, it create a 'temporary' registrey key under 'HEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2'
to save the new nickname.

But this nickname is stored under an UID key that is never reused by subsequent 'open file' dialog windows. So cbfs network drive return to its default name.

Is there a way to handle properly nickname of cbfs network drives ?

Franck Bonin

Posted: 07/04/2008 07:40:24
by Volodymyr Zinin (Team)


Unfortunately in the current version it's not possible. The CallbackFS network mounting points haven't been made completely yet. We are working on it (this task has high priority in our TODO list) and I think that this feature will work well.
We'll notify you as soon as we implement it completely.
Posted: 04/03/2009 08:58:56
by Kurt Griffiths (Standard support level)
Joined: 12/08/2008
Posts: 34

Any improvements on this for CBFS 2.5? I am still seeing the drive show up as "Network Drive". I would rather have it just use whatever is returned from the OnGetFileInfo callback.
Posted: 04/03/2009 11:28:46
by Volodymyr Zinin (Team)

If you use AddNetworkMountingPoint to create a network drive letter then a description that is shown near the drive in Explorer is specified by the contents of the MountingPoint parameter of this function. For instance "x:;server_name;share_name" will be visible in Explorer like a network drive "x:" with a description like "share_name on server_name (X:)".
If you see instead of this only the "Network Drive" text then perhaps the Network Redirector helper DLL (VSNetRdr.dll) is not correctly installed (or some older exists instead of the latest one).
Please ensure about it.
Posted: 04/03/2009 11:55:35
by Kurt Griffiths (Standard support level)
Joined: 12/08/2008
Posts: 34

I double-checked with Process Explorer and the correct version of the redirector helper DLL is indeed loaded. I have also rebooted the machine after installing the helper DLL. Still, on Vista (I haven't yet checked XP), the description isn't showing up. This is regardless of what I user for share_name and server_name.
Posted: 04/03/2009 15:50:56
by Sid Schipper (Standard support level)
Joined: 03/14/2008
Posts: 285

What Vladimir said works for me, so I'm guessing that Kurt has something else wrong with his call to AddNetworkMountingPoint. I had a similar problem when I first started using that API and it was because I failed to specify the string correctly when I called that function. Try running in Debug and making sure that the string you pass to AddNetworkMountingPoint is correct.
Posted: 04/04/2009 01:09:12
by Volodymyr Zinin (Team)

Installation of the helper dll must be processed under elevated administrator rights (i.e. as "run as admin"). Please check that the InstallHelperDll call finishes successfully (reboot the machine if it's necessary). And check after the installation whether the file VMNetRdr.dll is located in windows\system32 directory and has the same size and version as the installed one.
Also if you call AddNetworkMountingPoint with AuthenticationID == NULL (i.e. for the same session that calls AddNetworkMountingPoint) then in a case of calling the function from the elevated program (i.e. if a program that calls this function "runs as admin") the mounting point will be created for "administrator session" not for the original one. You can check it by running elevated Explorer - the mounting point would be shown there correctrly.
Posted: 04/08/2009 14:45:42
by Kurt Griffiths (Standard support level)
Joined: 12/08/2008
Posts: 34

I have gotten it to work fine on 2 out of 3 test machines, one running XP and the other Vista. The last machine is also running Vista, but no matter how many times I uninstall/reboot/reinstall/reboot, the network drive label always shows up as "Network Drive". I have verified that the latest version of VSNetRdr.dll is indeed installed in windows\system32 and that CallbackFileSystem::InstallHelperDll succeeds with no errors. In fact, I know that VSNetRdr.dll is loading correctly because I don't see the drives as "disconnected" in Windows Explorer.

I have tried various combinations of the following, with the same result:

1. Mounting in the global object namespace vs. current user
2. Passing Various CbFsNetworkSymLinkFlags to AddNetworkMountingPoint (including 0)
3. Passing an authenticationID for the current user vs. NULL
4. UAC on/off

I also noticed that the problematic Vista box had been upgraded to IE 8, so I installed IE 8 on the other Vista test machine and the network drive label continued to be set appropriately.

At this point I can't think of any reason why VSNetRdr.dll wouldn't work on all machines.
Posted: 04/09/2009 07:54:54
by Volodymyr Zinin (Team)

Could you create a virtual machine image (VMware is preferable) for the machine that contains the problem and send it to us?
If it's necessary I'll give any information how to do it.
Posted: 05/12/2009 14:30:17
by Kurt Griffiths (Standard support level)
Joined: 12/08/2008
Posts: 34

Unfortunately the one machine I had the problem on was my workstation, and that has since been wiped and a new OS installed on it. We are getting quite a few customers reporting the same problem. It seems to be intermittent - sometimes the drive name shows correctly, sometimes it is just "Network Drive". Rebooting, remounting, etc. does not fix the problem.

Has anyone else seen this problem in the wild? I am trying to figure out what we could have done wrong.



Topic viewed 8526 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!