EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Callback File System as console appication

Posted: 05/06/2008 06:06:55
by Søren Kristensen (Basic support level)
Joined: 03/04/2008
Posts: 62


I am trying to make CallBack Filesystem run as an console application.

I have started from the VDisk sample CPP, and as long as I do not create files it is OK. Hoverver when I try to create a file the CreateFile function gives me the following error:
ERROR_GEN_FAILURE: A device attached to the system is not functioning

Has anyone experience with CbFS running as console application?

Regards Soren
Posted: 05/06/2008 07:29:07
by Vladimir Lichman (Priority Standard support level)
Joined: 05/01/2008
Posts: 19

Yes, I run cbfs as console application and as Windows Service.
Posted: 05/06/2008 23:13:28
by Søren Kristensen (Basic support level)
Joined: 03/04/2008
Posts: 62

Hi again

The problem is solved. I had changed to a newer version of the driver without changing filehandle.cpp and filehandle.h. When I used these from the lates version everything is OK.

Posted: 05/28/2008 00:55:57
by Søren Kristensen (Basic support level)
Joined: 03/04/2008
Posts: 62


I have created an application that is going to run as service. When I run as console application, my drive is mapped and I can see it in the explorer. However when I run it as a service, I dont see my mapped drive in the explorer. Is there something I have missed?

Posted: 05/28/2008 02:57:11
by Volodymyr Zinin (Team)


You must use the AddMountingPointEx method for creation mounting points in user sessions. Also it's necessary to install the helper dll VSMntNtf.dll before (for details see the InstallHelperDll function description). Perhaps there's some problem in the latest build with installing this dll. We are currently working on it.
Posted: 05/28/2008 03:24:55
by Søren Kristensen (Basic support level)
Joined: 03/04/2008
Posts: 62

Just to be sure.

I have seen in another thread that the helper dll VSMntNtf.dll is only available in version 2.xx. I am running Driver (ver

Does this mean that it will not be possible to make this version running as a service?
Posted: 05/28/2008 03:52:36
by Volodymyr Zinin (Team)

It's possible for the 1.x versions too. But in this case you must call AddMountingPoint in the context of a session where the mounting point must be created.
The latest pre-release build is quite stable and we plan to make the 2.0 release in a few weeks. So you can start to use the latest version.
Posted: 07/01/2008 10:33:33
by Sid Schipper (Standard support level)
Joined: 03/14/2008
Posts: 285

I'm replying to this thread rather than opening a new topic because my question is highly related to the topics discussed above.

I am also trying to make my virtual disk application into a Windows service. Right now it runs fine as an MFC application, but when I try to run it as a service I also do not see my mount points in Windows explorer.

I installed the helper dll VSMntNtf.dll and I am using AddMountingPointEx and it still doesn't work. I tried two versions, one where I just made the mounting point a global one and another one where I use LsaEnumerateLogonSessions to get the LUIDs of all logged on users and added a local mount point for each of those users and that didn't work either. I'm wondering if I use LsaEnumerateLogonSessions and then Impersonate the user and then add the local mounting point if that will work. I'm going to try that next.

Meanwhile, if you have any insights into this problem I would appreciate your help.
Posted: 07/01/2008 10:50:28
by Eugene Mayevski (Team)

Explorer doesn't show the drive because it was not notified about drive list change. This has been discussed and described by Vladimir a number of times here (search by WM_DEVICECHANGE in this forum). I have no idea why VSMntNtf.dll doesn't work, but you can create your own test (!) application that will broadcast WM_DEVICECHANGE message in user context. This way you will see if it's the message that is the problem (and solution of the problem).

BTW can you navigate to the drive from command prompt?

Sincerely yours
Eugene Mayevski
Posted: 07/01/2008 11:31:45
by Sid Schipper (Standard support level)
Joined: 03/14/2008
Posts: 285

I could not navigate to the drive from the command prompt.

I did the search you suggested and got some sample code from Vladimir on how to broadcast the WM_DEVICECHANGE message.

I still would like to know whether I should add my mounting point as a global or a local mounting point?



Topic viewed 20920 times

Number of guests: 1, registered members: 0, in total hidden: 0


Back to top

As of July 15, 2016 EldoS business operates as a division of /n software, inc. For more information, please read the announcement.

Got it!