EldoS | Feel safer!

Software components for data protection, secure storage and transfer

Disable Preserve timestamp

Also by EldoS: CallbackDisk
Create virtual disks backed by memory or custom location, expose disk images as disks and more.
#10797
Posted: 08/17/2009 08:23:06
by Steve Cavanagh (Standard support level)
Joined: 03/10/2009
Posts: 10

I am using BizCrypto version 7.0.0.155 and I receive this error when attempting to updload a file: EldoS SFTP Adapter: Failed to transfer file(s): No such file

I am able to successfully upload to another ftp site. The site I am having problems with required me to change my WinSCP settings in order to avoid receiving an error uploading using that program, I had to disable the Preserve timestamp setting. I'm guessing that this might be the source of my problems.

Is there a way to disable the Preserve timestamp setting for the SFTP Adapter?

Thanks,
Steve Cavanagh
#10798
Posted: 08/17/2009 08:41:06
by Ken Ivanov (EldoS Corp.)

Thank you for contacting us.

SFTP adapter does not adjust file times, so I am not sure if the issue is related to timestamp preserving. Would you be so kind to provide us with the detailed connection log? Please adjust the following properties to obtain the log:
a) "Trace to File" to Yes,
b) "Trace to Event Log" to No,
c) "Trace Level" to Debug,
d) point "Trace Filename" to a disk file where the log should be written to.
#10799
Posted: 08/17/2009 10:27:04
by Steve Cavanagh (Standard support level)
Joined: 03/10/2009
Posts: 10

Log file is attached.

Thanks,

Steve


[ Download ]
#10800
Posted: 08/17/2009 11:52:05
by Ken Ivanov (EldoS Corp.)

Thank you for the log. Unfortunately, the problem needs further investigation -- the server returns a "No such file" error with no reason. Can you please provide us the following information so that we could try to localize the issue in our environment:
a) the name of the SSH/SFTP server-side software,
b) the value of "Compatibility Mode" of the adapter (BTW, please try setting this property to "Default" and "Old" and check if one of these settings help),
c) the values of the "Overwrite", "Append" and "ASCII mode" properties.
#10808
Posted: 08/18/2009 09:10:58
by Steve Cavanagh (Standard support level)
Joined: 03/10/2009
Posts: 10

Here are my rather limited answers:

a) I'm not sure what server software is being used. We are connecting to a clearing house.
b & c) I have tried various combinations of these settings to no avail.

Is there perhaps a more verbose logging mode that might provide more details to aid in the diagnosis.

Does the SFTP adapter attempt to read some attributes on the file that was uploaded after the upload has completed? If so, I'm guessing that this might be the problem.

Thanks,
Steve
#10829
Posted: 08/19/2009 12:00:35
by Ken Ivanov (EldoS Corp.)

Thank you.

Unfortunately, the Debug logging level is the most verbose one. Actually, there can be no more details to log -- the server returns a "No such file" error in response to OpenFile() call without providing the details. I think that we would need to create a small test application for you that will try to upload the file in several different modes in order to pick up the working one. We will provide you with this application tomorrow.
#10838
Posted: 08/20/2009 07:46:06
by Ken Ivanov (EldoS Corp.)

Let's continue the discussion in the Helpdesk. I have created a ticket for you.
#10856
Posted: 08/21/2009 12:06:49
by Steve Cavanagh (Standard support level)
Joined: 03/10/2009
Posts: 10

Thanks! I'll follow up with you via the helpdesk.

Steve
#10859
Posted: 08/21/2009 14:05:20
by Steve Cavanagh (Standard support level)
Joined: 03/10/2009
Posts: 10

Thank you very much for providing the test application. It turns out that your default file name "./dir/file" provided me with the solution to my problem. The problem was that I was not preceding the directory path with a period (".").

Including the "." in the path was not necessary for one of our clearinghouse connections, but was for the other.

Your prompt assistance is greatly appreciated. I have closed my helpdesk ticket.

Sincerely,

Steve Cavanagh
#10860
Posted: 08/21/2009 14:27:42
by Eugene Mayevski (EldoS Corp.)

In fact, proper naming is absolute path names (without leading period), i.e. /path/to/filename.ext. By adding the "." you have converted the path to the relative one. This is non-standard behaviour, but probably your server prefers non-standard paths ...


Sincerely yours
Eugene Mayevski
Also by EldoS: MsgConnect
Cross-platform protocol-independent communication framework for building peer-to-peer and client-server applications and middleware components.

Reply

Statistics

Topic viewed 6136 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!