EldoS | Feel safer!

Software components for data protection, secure storage and transfer

EldoS FTPS adapter: Error: Unaccepted server replyerror code is 534)

Also by EldoS: CallbackRegistry
A component to monitor and control Windows registry access and create virtual registry keys.
#9609
Posted: 04/08/2009 10:13:00
by Len Bertelli (Standard support level)
Joined: 04/08/2009
Posts: 16

I got the following error while setting FTPS adapter. Your help would be appreciated.

EldoS FTPS Adapter (transmit)
Message ID: 4c677b95-24c9-4ddc-be73-b45bbf003b76
URI: FTPS://SYU4WFTD@209.95.224.76:21/SYU4WFTD\/%25MessageID%25.xml

EldoS FTPS Adapter: Error: Unaccepted server reply (error code is 534)

Stack:
at SBSimpleFTPS.TElSimpleFTPSClient.DoSendCmd(String Command, Int16[] AcceptCodes, Boolean EstablishDataConnection)
at SBSimpleFTPS.TElSimpleFTPSClient.SendCmd(String Command, Int16[] AcceptCodes)
at SBSimpleFTPS.TElSimpleFTPSClient.Login()
at SecureBlackbox.BizTalk.Adapters.FTPS.FTPSCommon.DoFTPSOperation(IBaseMessage message, AdapterProperties props, Boolean upload, ArrayList fileList)

For more information, see Help and Support Center at
#9610
Posted: 04/08/2009 10:48:00
by Ken Ivanov (EldoS Corp.)

Thank you for contacting us.

This error is usually exposed if the server returned an unsuccessful or unexpected reply for some protocol command issued by the FTPS client (i.e. by the adapter).

To get the details, please do the following:
a) stop BizTalk Host Instance and the BizTalk application which uses the adapter,
b) set trace level to Debug in the adapter settings,
c) start BizTalk Host Instance and the application,
d) reproduce the problem.

As a result, the event log will contain the detailed log of the communication between the adapter and the server. It might shed more light on the reason for the issue you are encountering.
#9611
Posted: 04/08/2009 11:00:39
by Len Bertelli (Standard support level)
Joined: 04/08/2009
Posts: 16

Here is the detail information from Windows Event Viewer.

EldoS FTPS Adapter (transmit): __ctor()
EldoS FTPS Adapter (transmit): TransmitMessage()
EldoS FTPS Adapter (transmit): CreateProperties()
EldoS FTPS Adapter (transmit): ProcessMessage()
AdapterProperties::LoadFromMessageContext()
EldoS FTPS Adapter: Loading certificates
EldoS FTPS Adapter: Loading client certificate(s)
EldoS FTPS Adapter: 0 certificates loaded
EldoS FTPS Adapter: Loading trusted certificate(s)
EldoS FTPS Adapter: 1 certificates loaded
EldoS FTPS Adapter: Opening the connection
EldoS FTPS Adapter: Optionally performing SSL/TLS negotiation and logging in
> 220 CONNECT:Enterprise Gateway 2.0.02. S13 FTP Server ready... 11:53:16 04-08-2009
< AUTH TLS
> 234 AUTH: command accepted. Securing command channel ...
EldoS FTPS Adapter: Running certificate validation handler
EldoS FTPS Adapter: all certificates are trusted, exiting
< USER SYU4XWFTD
> 331 Password required for SYU4XWFTD.
< PASS ****************
> 230 User SYU4XWFTD logged in. Session Id: 98713.
< PBSZ 0
> 200 PBSZ command accepted.
< PROT C
> 534 PROT Request denied for policy reasons.
EldoS FTPS Adapter: Error: Unaccepted server reply (error code is 534)

Stack:
at SBSimpleFTPS.TElSimpleFTPSClient.DoSendCmd(String Command, Int16[] AcceptCodes, Boolean EstablishDataConnection)
at SBSimpleFTPS.TElSimpleFTPSClient.SendCmd(String Command, Int16[] AcceptCodes)
at SBSimpleFTPS.TElSimpleFTPSClient.Login()
at SecureBlackbox.BizTalk.Adapters.FTPS.FTPSCommon.DoFTPSOperation(IBaseMessage message, AdapterProperties props, Boolean upload, ArrayList fileList)
Error: Unaccepted server reply (error code is 534)
#9612
Posted: 04/08/2009 11:25:28
by Ken Ivanov (EldoS Corp.)

Your server seems to expect protected data channel, while the adapter is configured to use clear data channel. Please set Clear Data Channel property to false and check if it resolves the issue.
#9614
Posted: 04/08/2009 14:49:14
by Len Bertelli (Standard support level)
Joined: 04/08/2009
Posts: 16

That definitely helps. Now I don't see error or warning messages in the Windows Event Viewer Now. The file seems to be uploaded to the FTP site. However the file size is 0. The status of the file is incomplete in the Document Tracking web page.
#9615
Posted: 04/08/2009 15:36:27
by Ken Ivanov (EldoS Corp.)

Please try to set Passive Mode property to true. It is likely that the adapter is configured to use Active mode, which is usually blocked by the firewall.

If switching to passive mode does not help, please adjust the values of the following properties:
a) Adjust Passive Address to true,
b) Use SSL Session Resumption to false.
#9616
Posted: 04/08/2009 16:04:15
by Len Bertelli (Standard support level)
Joined: 04/08/2009
Posts: 16

#1 set Passive mode to true, the file size is still 0;
#2 set Passive mode to ture, Ajust Passive Address to ture, Use SSL Session Resumption to No. No lucky either.
#9624
Posted: 04/09/2009 08:32:33
by Ken Ivanov (EldoS Corp.)

Would you be so kind to post the exact log of the connection here or to Helpdesk (omitting sensitive information)?
#9625
Posted: 04/09/2009 08:40:15
by Len Bertelli (Standard support level)
Joined: 04/08/2009
Posts: 16

Below is the trace log. The adapter seetting is similar to #2

[4/9/2009 9:50 AM] AdapterProperties::LoadFromMessageContext()
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Loading certificates
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Loading client certificate(s)
[4/9/2009 9:50 AM] EldoS FTPS Adapter: 0 certificates loaded
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Loading trusted certificate(s)
[4/9/2009 9:50 AM] EldoS FTPS Adapter (transmit): __ctor()
[4/9/2009 9:50 AM] EldoS FTPS Adapter (transmit): TransmitMessage()
[4/9/2009 9:50 AM] EldoS FTPS Adapter (transmit): CreateProperties()
[4/9/2009 9:50 AM] EldoS FTPS Adapter (transmit): ProcessMessage()
[4/9/2009 9:50 AM] AdapterProperties::LoadFromMessageContext()
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Loading certificates
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Loading client certificate(s)
[4/9/2009 9:50 AM] EldoS FTPS Adapter: 0 certificates loaded
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Loading trusted certificate(s)
[4/9/2009 9:50 AM] EldoS FTPS Adapter: 1 certificates loaded
[4/9/2009 9:50 AM] EldoS FTPS Adapter: 1 certificates loaded
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Opening the connection
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Opening the connection
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Optionally performing SSL/TLS negotiation and logging in
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Optionally performing SSL/TLS negotiation and logging in
[4/9/2009 9:50 AM] > 220 CONNECT:Enterprise Gateway 2.0.02. S11 FTP Server ready... 09:50:40 04-09-2009

[4/9/2009 9:50 AM] < AUTH SSL
[4/9/2009 9:50 AM] > 234 AUTH: command accepted. Securing command channel ...

[4/9/2009 9:50 AM] > 220 CONNECT:Enterprise Gateway 2.0.02. S13 FTP Server ready... 09:50:40 04-09-2009

[4/9/2009 9:50 AM] < AUTH SSL
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Running certificate validation handler
[4/9/2009 9:50 AM] EldoS FTPS Adapter: all certificates are trusted, exiting
[4/9/2009 9:50 AM] > 234 AUTH: command accepted. Securing command channel ...

[4/9/2009 9:50 AM] EldoS FTPS Adapter: Running certificate validation handler
[4/9/2009 9:50 AM] EldoS FTPS Adapter: all certificates are trusted, exiting
[4/9/2009 9:50 AM] < USER SYU4WFTD
[4/9/2009 9:50 AM] > 331 Password required for SYU4WFTD.

[4/9/2009 9:50 AM] < PASS ****************
[4/9/2009 9:50 AM] < USER SYU4WFTD
[4/9/2009 9:50 AM] > 331 Password required for SYU4WFTD.

[4/9/2009 9:50 AM] < PASS ****************
[4/9/2009 9:50 AM] > 230 User SYU4WFTD logged in. Session Id: 39406.

[4/9/2009 9:50 AM] < PBSZ 0
[4/9/2009 9:50 AM] > 200 PBSZ command accepted.

[4/9/2009 9:50 AM] < PROT P
[4/9/2009 9:50 AM] > 200 PROT command accepted. Data transactions will be secured.

[4/9/2009 9:50 AM] < FEAT
[4/9/2009 9:50 AM] > 500 FEAT command not understood.

[4/9/2009 9:50 AM] EldoS FTPS Adapter: Logged in
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Uploading file(s)
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Remote path is SYU4WFTD/2009-04-09T095039.txt
[4/9/2009 9:50 AM] EldoS FTPS Adapter: ProcessMessage() Sending file to: SYU4WFTD/2009-04-09T095039.txt
[4/9/2009 9:50 AM] < TYPE A
[4/9/2009 9:50 AM] > 200 TYPE Command okay.

[4/9/2009 9:50 AM] < PASV
[4/9/2009 9:50 AM] > 227 PASV Entering passive mode (10,35,72,27,8,89).

[4/9/2009 9:50 AM] < STOR SYU4WFTD/2009-04-09T095039.txt
[4/9/2009 9:50 AM] > 230 User SYU4WFTD logged in. Session Id: 12290.

[4/9/2009 9:50 AM] < PBSZ 0
[4/9/2009 9:50 AM] > 200 PBSZ command accepted.

[4/9/2009 9:50 AM] < PROT P
[4/9/2009 9:50 AM] > 200 PROT command accepted. Data transactions will be secured.

[4/9/2009 9:50 AM] < FEAT
[4/9/2009 9:50 AM] > 500 FEAT command not understood.

[4/9/2009 9:50 AM] EldoS FTPS Adapter: Logged in
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Uploading file(s)
[4/9/2009 9:50 AM] EldoS FTPS Adapter: Remote path is SYU4WFTD/2009-04-09T095040.txt
[4/9/2009 9:50 AM] EldoS FTPS Adapter: ProcessMessage() Sending file to: SYU4WFTD/2009-04-09T095040.txt
[4/9/2009 9:50 AM] < TYPE A
[4/9/2009 9:50 AM] > 200 TYPE Command okay.

[4/9/2009 9:50 AM] < PASV
[4/9/2009 9:50 AM] > 227 PASV Entering passive mode (10,35,72,29,11,18).

[4/9/2009 9:50 AM] < STOR SYU4WFTD/2009-04-09T095040.txt
#9627
Posted: 04/09/2009 09:02:12
by Ken Ivanov (EldoS Corp.)

At first glance, data channel connection fails to be established for some reason. Please set Socket Timeout and Transfer Timeout properties to relatively small values (e.g., 20000) and try to upload the file again. The log should contain more details now (timeout exceeded error and some further entries), which may shed some light on the reason for the issue.

May I also ask you to pass exactly one file to the adapter to prevent logs from several sessions from mixing.
Also by EldoS: CallbackRegistry
A component to monitor and control Windows registry access and create virtual registry keys.

Reply

Statistics

Topic viewed 27204 times

Number of guests: 1, registered members: 0, in total hidden: 0




|

Back to top

As of July 15, 2016 EldoS Corporation will operate as a division of /n software inc. For more information, please read the announcement.

Got it!