Discuss this help topic in SecureBlackbox Forum


TElSimpleSSLClient     See also     

Filter: C#/Java  VB.NET  Pascal  C++  PHP  

Specifies the allowed SSL/TLS versions.


    short Versions;

    Property Versions As Short

    property Versions : TSBVersions;
    TSBVersions = set of TSBVersion;

    not available

    not available


  • Version - The value that is to be enabled or disabled. See the list of values below



    This property defines which SSL/TLS versions are allowed to be used during SSL/TLS session. By default all versions are allowed. The application can disable undesired versions. It is not possible to disable SSL3 if TLS1 and SSL2 are both enabled.
    Default value is [sbSSL2, sbSSL3, sbTLS1, sbTLS11].
    Note, if you set Versions to [sbSSL3, sbTLS1] and connect to Java 2 server which supports only TLS1, Java server will crash. This is a bug in Java 2 server.
   Note, protocol version assigning differs in VCL and .NET versions. To enable some SSL versions in .NET use bitwise OR operation, for example ‘sbSSL2 | sbSSL3 | sbTLS1’.

    Example:  The following shows how to set the property for different SecureBlackbox editions:

    TElSimpleSSLClient.Versions = SBConstants.Unit.sbSSL2 | SBConstants.Unit.sbSSL3 | SBConstants.Unit.sbTLS1;

    TElSimpleSSLClient.Versions = SBConstants.Unit.sbSSL2 Or SBConstants.Unit.sbSSL3 Or SBConstants.Unit.sbTLS1

    TElSimpleSSLClient.Versions = sbSSL2 or sbSSL3 or sbTLS1;

See also:     CipherSuites    

Discuss this help topic in SecureBlackbox Forum