Discuss this help topic in SecureBlackbox Forum


TElSimpleFTPSClient     See also     

Filter: C#/Java  VB.NET  Pascal  C++  PHP  

Specifies the allowed SSL/TLS versions.


    TSBVersions Versions;

    Property Versions As TSBVersions

    property Versions : TSBVersions;
    TSBVersions = set of TSBVersion;

    TSBVersions get_Versions();
    void set_Versions(TSBVersions Value);

    integer get_Versions()
    void set_Versions(integer $Value)


  • Version - The value that is to be enabled or disabled. See the list of values below


TSBVersions values


    This property defines which SSL/TLS versions are allowed to be used during SSL/TLS session. By default all versions are allowed. The application can disable undesired versions. It is not possible to disable SSL3 if TLS1 and SSL2 are both enabled.
    Default value is [sbSSL2, sbSSL3, sbTLS1, sbTLS11].
     Note, if you set Versions to [sbSSL3, sbTLS1] and connect to Java 2 server which supports only TLS1, Java server will crash. This is a bug in Java 2 server.
    Note, protocol version assigning differs in VCL and .NET versions. To enable some SSL versions in .NET use bitwise OR operation, for example ‘sbSSL2 | sbSSL3 | sbTLS1’.

    Example:  The following shows how to set the property for different SecureBlackbox editions:

    TElSimpleFTPSClient.Versions = SBConstants.Unit.sbSSL2 | SBConstants.Unit.sbSSL3 | SBConstants.Unit.sbTLS1;

    TElSimpleFTPSClient.Versions = SBConstants.Unit.sbSSL2 Or SBConstants.Unit.sbSSL3 Or SBConstants.Unit.sbTLS1

    TElSimpleFTPSClient.Versions = sbSSL2 or sbSSL3 or sbTLS1;

See also:     CipherSuites     Version    

Discuss this help topic in SecureBlackbox Forum