Discuss this help topic in SecureBlackbox Forum

TElSftpVersionsExtension.Versions

TElSftpVersionsExtension     


Filter: C#/Java  VB.NET  Pascal  C++  PHP  


Specifies sever supported versions

Declaration

[C#/Java]
    TSBSftpVersions Versions;

[VB.NET]
    Property Versions As TSBSftpVersions

[Pascal]
    property Versions : TSBSftpVersions;
    TSBSftpVersions = set of TSBSftpVersion;

[C++]
    TSBSftpVersions get_Versions();
    void set_Versions(TSBSftpVersions Value);

[PHP]
    integer get_Versions()
    void set_Versions(integer $Value)

Values:


TSBSftpVersions values

Description

    Use this property to specify versions supported by server.

    Example:  The following shows how to set the property for different SecureBlackbox editions:

[C#/Java]
    TElSFTPSSHSubsystemHandler.Versions = SBSftpCommon.Unit.sbSFTP4 | SBSftpCommon.Unit.sbSFTP5 | SBSftpCommon.Unit.sbSFTP6;

[VB.NET]
    TElSFTPSSHSubsystemHandler.Versions = SBSftpCommon.Unit.sbSFTP4 Or SBSftpCommon.Unit.sbSFTP5 Or SBSftpCommon.Unit.sbSFTP6

[Pascal]
    TElSFTPSSHSubsystemHandler.Versions := sbSFTP4 or sbSFTP5 or sbSFTP6;

Discuss this help topic in SecureBlackbox Forum